Minimum Requirements

We made Quix the best Page Builder for Joomla users. To install Quix and avoid any issues, there are some minimum system requirements that must be met by your system/server. After Quix is installed on your site, you can go to Quix - Help to see if you meet the minimum requirements, or if you need to update some settings.

Quix - Minimum Requirements

Device

Right now, you need to use a Desktop or Laptop for installing Quix and for creating/editing content, you cannot do it on tablets or mobile phones.

Joomla Version

This documentation is based on the stable version of Joomla 3.9+. Quix will only work properly on Joomla 3.5.0 and above.

PHP Version

Currently both Joomla and Quix need PHP version 7.2.x or higher to work properly, earlier versions are no longer supported and can create problems on your site. So if you are not currently using PHP 7.2.x or higher, please contact your hosting provider and ask them to update your PHP version.
Please note that PHP 7.4 is not yet fully supported, we recommend using PHP 7.2.x or 7.3.x

PHP Extensions

cURL - Enabled
Client URL (cURL) allows you to get connected to extenral URLs and use their response in your code. Without it, Quix won’t get installed on your site.

cType - Enabled
cType extension provides the functions to check that the characters in a string are the correct type. It is also necessary for Quix.

GD Library - Enabled
The GD Graphics Library is a graphics software library for dynamically manipulating images. It can create JPEGs, PNGs, and WBMPs. It is needed so that QuixOptimize can work properly.

PHP Settings

In your PHP settings, there are some that need to be properly configured to make sure Quix will work without issues, the most important ones and their minimum vaules are:

  • max_execution_time=60
  • memory_limit=128M
  • post_max_size=10M
  • upload_max_filesize=10M

You can contact your hosting provider and ask them to change the default values to the minimum required or to our recommended ones:

  • max_execution_time=300
  • memory_limit=128M
  • post_max_size=64M
  • upload_max_filesize=32M

Database engine

Since Quix 2.0.0 MySQL 5.6 is required for it to work. Please contact your hosting provider to see if it is installed on your server or if it has to be updated. Please note that Quix can also work with the MariaDB equivalent version.

Browser Requirements

Preferred minimum versions for the back-end administration of Quix are (Internet Explorer and Edge are not supported):

  • Google Chrome 70+
  • Firefox 65+
  • Safari 11+
  • Opera 56+
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us